请选择 进入手机版 | 继续访问电脑版

葡萄城产品技术社区

    注册

QQ登录

SpreadJS

纯前端控件,类似Excel,问题响应通道

ComponentOne WPF

前沿科技,针对WPF桌面,问题响应通道

C1FlexGrid视频教程

WinForm平台,功能强大的表格控件,初学者必看视频

ActiveReport视频教程

轻松搞定报表,从头开始学AR,视频教程

搜索
查看: 714|回复: 6

SpreadJS 10.0 v2 正式发布啦!

[复制链接]

46

主题

265

帖子

2975

积分

超级版主

Rank: 8Rank: 8

积分
2975

微信认证勋章答侠葡萄

发表于 2017-7-26 14:03:35 | 显示全部楼层 |阅读模式
本帖最后由 Helen 于 2017-7-28 12:03 编辑

本次发布SpreadJS表格支持了Angular2。并基于用户反馈做了不少的提升和增强,更稳定更易用。还在等什么?赶快试用吧:
下载SpreadJS10v2

本次发布版本的新特性?
SpreadJS表格
支持Angular2
1.png
支持韩语
设计器界面支持产品新功能
  • 支持单元格的内边距和标签(Label)设置
2.png
  • 支持在工作表/行/列/单元格上设置标签属性(Tag)
  • 支持剪切板设置
3.png
  • 支持范围选择模式
4.png
  • 支持年度和月度迷你图
5.png
SpreadJS视图
设计器全面汉化
6.png

更多新版本细节信息
想了解本次发布版本的新增接口和问题修复,更多细节请参考发布说明
我是否需要新的 License ?
如果您之前已经购买了SpreadJS的授权并在金牌服务期内,那么您可以免费升级到10.2。
如果您并未购买SpreadJS的授权或者不在金牌服务期内,那么您需要申请新的授权序列号。
详细申请步骤请咨询葡萄城控件业务部:
邮箱:sales.xa@grapecity.com电话:400-657-6008

回复

使用道具 举报

13

主题

47

帖子

2687

积分

金牌服务用户

积分
2687
发表于 2017-7-26 16:50:25 | 显示全部楼层
赞,请问如何升级到10.2?我直接替换js和css文件后提示无效的许可证
回复 支持 反对

使用道具 举报

46

主题

265

帖子

2975

积分

超级版主

Rank: 8Rank: 8

积分
2975

微信认证勋章答侠葡萄

 楼主| 发表于 2017-7-26 17:49:21 | 显示全部楼层
Jobcrazy 发表于 2017-7-26 16:50
赞,请问如何升级到10.2?我直接替换js和css文件后提示无效的许可证

已购用户请将公司名称发送邮件到support.xa@grapecity.com,我们会将正式版下载地址发送给您。
回复 支持 反对

使用道具 举报

0

主题

1

帖子

8

积分

注册会员

积分
8
发表于 2017-9-20 15:46:02 | 显示全部楼层
从9.04能平滑升级到时10.2吗,好象js改了很多啊,要重新一点一点改吗?
回复 支持 反对

使用道具 举报

11

主题

1993

帖子

1万

积分

超级版主

Rank: 8Rank: 8

积分
12392
发表于 2017-9-20 17:50:22 | 显示全部楼层
您好,V10中对接口进行了优化,功能更加模块化,使得接口调整幅度较大,V9老用户升级可以参考这个博客的内容:
http://blog.gcpowertools.com.cn/ ... readsheets-V10.aspx

上面方法只是临时的一种权宜之策,并不是长远之计,所以建议您老的模块可以使用上面的方法先运行起来,新构建的模块建议使用V10的写法来写,这样同时也是在学习熟悉V10的接口,之后将老的模块慢慢的迁移至V10的写法。
请点击评分,对我的服务做出评价!5分为非常满意!

葡萄城控件服务团队
官方网站: http://www.gcpowertools.com.cn
回复 支持 反对

使用道具 举报

0

主题

1

帖子

312

积分

中级会员

积分
312

微信认证勋章

发表于 4 天前 | 显示全部楼层
问下,spreadJS10支持requireJS么?用requireJS加载gc.spread.excelio.10.0.1.min.js无法导出EXCEL
回复 支持 反对

使用道具 举报

20

主题

5650

帖子

3万

积分

超级版主

Rank: 8Rank: 8

积分
35890

GrapeCity微信认证勋章

发表于 4 天前 | 显示全部楼层
ssf 发表于 2017-10-13 08:42
问下,spreadJS10支持requireJS么?用requireJS加载gc.spread.excelio.10.0.1.min.js无法导出EXCEL

您好,SpreadJSV10现在还没有完全支持AMD,如果要用需要用shim的方式加载js。

V11会完整支持
请点击评分,对我的服务做出评价!  5分为非常满意!
葡萄城控件服务团队
官方网站: http://www.gcpowertools.com.cn
回复 支持 反对

使用道具 举报

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

欢迎关注葡萄城控件

小黑屋|手机版|Archiver|葡萄城控件官网 ( 沪ICP备05020274号

GMT+8, 2017-10-17 05:53 , Processed in 1.142622 second(s), 34 queries .

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表